Skip to content
+1-888-319-3663

COMMUNITY FORUM

Error message when attempting to create new customeraddress record in CRM

Mike asked 5 years ago
I’m getting an error message when I attempt to run a map that uses Microsoft GP Change Data Source as the data source and Microsoft Dynamics CRM is the destination. I’m getting an error message, stating “Incorrect attribute value type System.String For entity ‘customeraddress’ where ‘name = ACME Widgets,’ in organization ‘CRMSandbox’.” I have a similar map that maps to CRM entity, account that has the exact same data types mapped to the Address columns as the customeraddress map, with the one exception that I am also mapping the System User to the Owner column using an entity lookup column.

I noticed that the Owner column is a data type of Owner instead of Lookup data type like the Modified By column. I am able to successfully use an entity lookup column to map the system user to the Modified By column. I’m wondering if the mapping to this “Owner” column in the customeraddress map is the culprit.
Has anyone else encountered this issue before?
Ethan Sorenson Staff replied 5 years ago

Mike,
I tried to recreate your scenario, and I got an error from CRM saying that I couldn’t populate the owner column of the customer address entity. I didn’t map a field to the owner and it worked. In CRM you don’t have to map fields even if they say “required.”
My error was different than yours, so I would recommend double checking your mappings to make sure the data is going into the correct fields.


If you would like to submit an answer or comment, please sign in to the eOne portal.