Skip to content
+1-888-319-3663

COMMUNITY FORUM

Duplicate PO Number Line

Tanya Henderson asked 3 years ago
 The map imports the first item and says the second has a duplicate.  My map has a key fields of PO and Item so they are unique.  The PO number is being passed in and not generated.  I have tried to dump it to a file and I get two XML files that look fine, but not sure why i get two i would assume i should get one with two items.  If i remove the PO number and let it generate it is successful, but it puts it on two different PO’s.  It seems that it will not group on the header.  I am using a query to get the data from an Excel file instead of just connecting to the Excel file because we are basing it off of a field in the file to know where to import or not.  This is the query very simple.
SELECT * FROM [Sheet1$] WHERE [IMPORT] = ‘Y’
Any help is appreciated as i have been fighting this for a while and have tried everything i can think of.
Tanya
Answers
Patrick Roth Staff answered 3 years ago
“and I get two XML files that look fine”
That is your clue.
If you get two files but there is date from one or the other missing, that would imply a grouping issue.
The two files is also why the document exists after the integration – the first works and is committed and the 2nd is a duplicate and rolled back in SQL.  Or else if you use GP Rolling Column then you would get two documents with just the PO number different?
More than likely the issue is the destination company.
You have the destination company marked by the destination checkbox. That is typical.
What you also have in that window is a “Define” script under that button. And that is returning the same company database name.
So SC processes the “define” company destination and then the checked company.  And now you have two POs.
Remove either one of these and you’ll get just the one document as you expect.
Tanya Henderson answered 3 years ago
It was a grouping issue and we got it resolved.  

If you would like to submit an answer or comment, please sign in to the eOne portal.