Skip to content
+1-888-319-3663

COMMUNITY FORUM

Different outcomes when map is run via web service versus SmartConnect UI

Jeff asked 3 years ago
I have an application that sends invoices to GP using the SmartConnect web service. When I run the map inside of the SmartConnect app, it completes fine. When I run the map via the soap web service, it fails and I receive the response “The map failed”. What could be causing this issue?
Under Map Setup > Options > Debug i checked all the boxes and reran the map again. I checked the debug log, only the run invoked via the web service showed an error.
I found the error under the Setup tab in the Map Debug Log. The message is: Assembly compilation failed. The detailed message is: Unreachable code detected The name ‘_PAYEEVENDORID’ does not exist in the current context
_PAYEEVENDORID is a field from my datasource. I have a calculated field that uses this value to query the database. I can validate this code successfully. I suspect this is causing the error when I invoke the web service.
Thanks for any help.
Patrick Roth Staff replied 3 years ago

You would want to take a look at the column names that you are sending in via the web service vs what is in the source and make sure they are 100% the same.

In that debug log where you get the error, you should be able to see the data and column names that the map has captured to then look to verify that the column is coming in how you expect.

Or I should say, how SC is expecting it.
You are getting this specific error because the name isn’t there and you are referencing it in code and so the compilation fails because the compiler cannot resolve _PAYEEVENDORID.


If you would like to submit an answer or comment, please sign in to the eOne portal.