Skip to content
+1-888-319-3663

COMMUNITY FORUM

Custom node will not fail

David Jedziniak asked 7 years ago
I have created a custom econnect proc, complete with pre and post procs.
I added a reference to this proc using node maintenance.
I created a map with a destination of the custom node and mapped the fields to my custom proc.
I set the source to a single record.
When I run the map, it reports success for 1 record.
However, I know it should fail.  When I run the proc manually against the same values using SSMS, I get back the the correct number in error state and errmessage variables.  The proc also correctly returns the errorstate value.  
I have validated that the proc is not doing the insert in the map or in SSMS (since it is failing).  How do I get smartconnect to realize the record failed?
 
 
Lorren Zemke replied 7 years ago

Dave, can you send me your stored proc and map and datasource?

David Jedziniak replied 7 years ago

I figured out the issue last night. For some reason, when I typed the name of the proc in to node maintenance, it was tying to the post proc, rather than the main one. (A SQL trace helped me figure that out). I had to drop the post proc from the database, create the node, then re-add the post proc to the database and it now runs fine.
This was on 20.13.1.89


If you would like to submit an answer or comment, please sign in to the eOne portal.