Skip to content
+1-888-319-3663

COMMUNITY FORUM

Conversion failed when converting…

Alberto Pinal asked 6 years ago
Hi,

I have a map that is Reading information from a SQL Server Data Source and with a SQL Table destination. So I am receiving an error when I try to integrate the info, this message is like this:

“Conversion failed when converting character string to smalldatetime data type”

I checked de field of the data Source and the field of the destination table and they are the same type, so I don’t know why I am receiving this error.

I hope you can help me!

Thanks.
Mark Anderson Staff replied 6 years ago

This is most likely due to the datetime format from the source SQL server does not match the datetime format on the destination SQL Server. Could be something like MM/DD/YYYY vs DD/MM/YYYY . You would need to verify the small date time format on the destination server to ensure it can accept the datetime format from the source server.

Alberto Pinal replied 6 years ago

Thanks a lot Mark, I have solved the problem, the datetime formats did not match…

Mikki replied 5 years ago

I am getting the same error in Smartview. However, it works perfectly in smartlist. I have a smartlist summary report GOTO a smartlist detail report. I receive the date conversion error only in smartview. The date format and SQL view and fields are identical. Is this a bug in smartview?

Allison replied 4 years ago

Does anyone have a resolution to Mikki’s post on January 18th? I have the same issue. Please advise

Patrick Roth Staff replied 4 years ago

since your issue is with an entirely different product (though with similar error) and isn’t resolved by this (solved) thread, you should re-ask this question in the SmartView forums as a new question.


If you would like to submit an answer or comment, please sign in to the eOne portal.