Skip to content
+1-888-319-3663

COMMUNITY FORUM

Change from using AD user to Single Credential

Charles asked 6 years ago
SmartConnect was configured to use AD credentials but the customer would like to change it to a single credential.
The GP Connector setup was changed and a credential was supplied.
The maps were reregistered.
However, when the map is run, a message appears that the Windows user logged into SmartConnect does not have rights to the company database. After adding that Windows login to SQL and to the database and to the Dynamics database, the error went away and the map run.
What am I missing in changing to using a single user?
This is 20.15.0.51.
Answers
Patrick Roth Staff answered 6 years ago
On the machine you are running SmartConnect on, look in Windows Services.  Find the eConnect for Microsoft Dynamics GP and look at the configured identity.
Verify that that user is set to DYNGRP and has access to the DYNAMICS and GP company db.
In SmartConnect in the connector setup, make sure that the checkbox for “Ignore Service Proxy” is Un-marked.
Doing it this way will make eConnect use the service user as the sql login user.
The only place you would have to watch otherwise is if you have code or a connection somewhere that does a SQL connection using windows auth.
you’ll find out when you run the map again …
Patrick
eone
 

If you would like to submit an answer or comment, please sign in to the eOne portal.