Skip to content
+1-888-319-3663

COMMUNITY FORUM

Adding new node – Error node does not exist.

Patty asked 6 years ago
Answers
Patty answered 6 years ago
I am adding a new node.  The stored procedure has been added in SQL.  I am trying to setup in Create /Update Node.  I put the stored procedure in the Technical name but I get the error The node does not exist.  I am not sure how to tell it what database the stored proc is located.  My default company is in the GP connector is the database where the stored procedure is located.  
 
Patrick Roth Staff answered 6 years ago
Patty,
SC looks at the default database that you’ve set up on the GP connector when you are setting up the new Nodes.
Your reply does imply that you did put the proc in that location but still get the error.
The one thing I can think of maybe is that your proc isn’t in the expected “eConnect” format. 
Your proc must have the params:
@O_iErrorState int output,  /* Error Code                 */
@oErrString varchar(255) output /* Comma separated list of errors encountered        */
at the end of it so that it is what eConnect expects.
If I just create a proc with whatever params and try to set it up in Create/Update Node window I get the same “The node does not exist.” error – the same as if I enter a proc that does not exist.
So I would suspect this is your issue.
Patrick
eOne
 
Edward replied 3 years ago

Getting the same message and verified the two parameters are included at the end of the proc. What else to check?

patty replied 3 years ago

your parameter field names must start with @I_vFIELDNAME

Edward replied 3 years ago

Thank you, that was the trick. In addition, the eConnect Service had to be restarted after creating the proc for SC to find it.

Patty answered 6 years ago
this solved the issue.    THANKS
 

If you would like to submit an answer or comment, please sign in to the eOne portal.