Skip to content
+1-888-319-3663

COMMUNITY FORUM

2016 Install error: Get/Change on EXT_Table_Cache: Invalid object name DYNAMICS.dbo.EXT90106

Steve Endow asked 4 years ago
I’m performing a new install of Extender 16.00.0050 on a vanilla GP 2016 RTM install with only the Fabrikam demo database.  When Extender attempts to create its tables, it immediately fails with this error:
A get/change operation on table EXT_Table_Cache cannot find the table
In More Info:
Invalid object name ‘DYNAMICS.dbo.EXT90106’.
In SQL Profiler, I see two statements:
exec DYNAMICS.dbo.zDP_EXT90106SS_2 3107,’EXT_Extender_Forms’
SELECT TOP 25 PRODID,Series_Number,TABLTECH,TABLDESC,DEX_ROW_ID FROM DYNAMICS.dbo.EXT90106 WHERE PRODID = 3107 AND TABLTECH = ‘EXT_Extender_Forms’ ORDER BY PRODID ASC ,TABLTECH ASC 
 
I’ve tried removing Extender from the SET file and reinstalling, but I get the same results.
Any suggestions?
 
Answers
Steve answered 4 years ago
I’ve tried installing on a second GP 2016 RTM server, and get the exact same results.  
Here is a screen shot:
Extender 2016 Install Error
https://1drv.ms/i/s!Au567Fd0af9Tmxg4Iplx6fqukTCw
 
Steve answered 4 years ago
I’ve now tried installing Extender 16.00.0050 on three different servers with both GP 2016 RTM and GP 2016 R2 with a fresh TWO database, and I get the same error when the Extender install process in GP starts to run.  The table creation process fails immediately.
 
Is there a different GP 2016 release that installs properly?
Steve answered 4 years ago
It seems that Extender 16 Build 50 is expecting the EXT90106 table to exist, even on a fresh GP install, causing the install script to fail if the table is not present.
I found a copy of the table on an old GP 2013 server, scripted it out in SSMS, and created the table on my GP 2016 machine. With the EXT90106 table created, the Extender installation process in GP appears to have completed without error.
I’ll be importing the client’s Extender export file and will see if it works okay.
Patrick Roth Staff answered 4 years ago
I’ll have to test out the new version – that one has been out just a few weeks.  Seems odd that it would be different than previous installs…
Your solution is good – otherwise when you got logged into GP (assuming the process doesn’t just halt here) you could use SQL Maintenance to create the extender tables (all but the v11-xXXX ones which are the old ones we don’t care about)
 
Ben Atkinson replied 4 years ago

I have been able to bypass this error by manually creating the autoproc and table for that specific table ‘Dyanmics GP Table Cache’ using GP SQL Maintenance: MS Dyanmics GP>>Maintenance>>SQL: choose Dynamics as the DB and Extender as the product. Find the table and recreate the auto proc and table. You can then exit and renter GP to build the rest.


If you would like to submit an answer or comment, please sign in to the eOne portal.